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About the Guide 

This guide is structured so that you get the most out of your learning experience. 

The concepts are delivered by the instructor either by discussion or demonstration. The 
guide is intended as a learning resource and is yours to keep after the training is 
completed. 

 
 

Disclaimer of Warranties and Limitations of Liabilities 

Alemba has made all reasonable efforts to ensure the accuracy of information in this 
document. However, nothing herein modifies or alters in any way the standard terms 
and conditions of the purchase, lease, or license arrangement by which the product was 
acquired, nor increases in any way Alemba’s liability to the customer. In no event shall 
Alemba be liable for incidental or consequential damages in connection with or arising 
from the use of the product, the accompanying manuals, or any related product. 

 
 

Copyright 

Copyright © Alemba Limited (or its licensors, including ©2010 - 2019 VMware, Inc). All rights reserved. This 
product is protected by U.S. and international copyright and intellectual property laws. VMware products 
are covered by one or more patents listed at: http://www.vmware.com/go/patents. VMware is a registered 
trademark or trademark of VMware, Inc. in the United States and/or other jurisdictions. VMware Service 
Manager™ is also trademark of VMware, Inc. Alemba™, vFire™ and vFireCore™ are trademarks of Alemba 
Limited (vFire Core™ is developed by Alemba Limited from VMware, Inc’s product “VMware Service 
Manager", under licence from VMware, Inc). All other marks and names mentioned herein may be 
trademarks of their respective companies. 

  

As the data is subject to change, any statistical information in screen examples may 
differ from your installation. 

http://www.vmware.com/go/patents


Alemba User Conference 2019: Alemba Service Manager Skills 
 

4 Alemba Dashboard Designer Version 1.0 

© Alemba  

 

 

Welcome to the Alemba User Conference 2019 Training 

This year, we are here to show you how to use our new third-party dashboard tool, Syncfusion. 

In the first session we will look at Dashboarding, and topics during this session will include: 

• Creating a Dashboard 

• Creating different types of widgets within a Dashboard 

• Manipulating the Data display to show different statistical information 

• Linking dashboards, so that you can drill down between dashboard displays 

This session is fully interactive. You can work along with the instructor during the teaching 
section and will have time to complete an exercise at the end that is designed to reinforce 
your learning and give you an opportunity to put your skills into practice. 
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Using the Alemba Dashboard Designer 

This section will give you some guidance to how to launch the Dashboard 
Designer application and an overview of the main areas of the screen.  

 
 
 

1. Launch the Alemba Dashboard Designer, using the icon on your desktop.  

2. The Dashboard Designer screen is displayed, containing the following elements: 

o The Dashboard Designer Main Menu 

• File - Create New Dashboard, Open, Save, Import, Export 

• Edit - Copy, Paste, Undo, Redo 

• Dashboard - Add a new Dashboard Page to the existing Dashboard. Launch 
a Preview, set a global Parameter, set global Filters, configure the 
Dashboard Refresh Settings and enable/ disable commenting for the 
current dashboard. 

• Data Source - Add or Import a Data Source. 

• Widget - Import or manage Custom Widgets. 

• Server - Uploading Dashboards, Widgets or Data Sources to the 
Dashboard Server. 

• Help - Access to the Online Help, Tracing (for use in diagnosing Support 
Queries) and viewing the Log Files. 

o The Dashboard Design Tools Pane 

• This pane will display relevant options for the selected widget in the Design 
View, allowing you to give the widget a name, assign data (from a 
configured Data Source) and present widget options. 

o Preview 
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• This button will launch the Dashboard in a browser so the dashboard can be 
tested in real time, and if configured will allow you to preview a dashboard 
using other users permissions/roles. 

o Toolbox Pane 

• The Toolbox Pane consists of data visualizations, filters and miscellaneous 
widgets which you can use to design an interactive dashboard. Drag the 
desired widget onto the Design Area and resizing it using the usual marquee 
points. 

o Element Containers 

• Dashboards 

• This container allows you to add or remove Dashboards, adding more than 
one dashboard will display each dashboard as a separate page to that can 
be linked to from within this Dashboard or from any other Dashboard. 

• Data Sources 

• This Container allows you to add, modify or remove Data Sources which 
can then be used to display the data within the many Chart or Filter 
Widgets. Typically, you will connect to the Alemba Service Manager 
Database using either a SQL Server Connection or via the Alemba API. 

• Widgets 

• Each Dashboard page will contain one or many widgets. Widgets can be 
used for display purposes, adding user definable filters to a dashboard page 
or displaying the data using one of the many chart or grid styles available. 

• Linked Dashboards 

• Displays a list of the Dashboards that Widgets on the Current Dashboard 
Page have been linked to. 

o Responsive Dashboard Design View 

• This is a 24 by 12 grid view where Widgets can be dragged from the Toolbox 
Pane. Widgets can then be positioned and re-sized to design the Dashboard 
page. The Dashboard Design view shows a responsive web page view and is 
used to display the widgets proportionally on a monitor, large screen or mobile 
device. You can extend the height of the Dashboard Pages by dragging a 
widgets height beyond the bottom of the grid to automatically add additional 
rows. 

  



Alemba User Conference 2019: Alemba Service Manager Skills 
 

7 Version 1.0 

© Alemba 
2018 

Alemba Dashboard Designer 

 

 

Scenario: Global Team Workload Dashboard 

The User Day Skills Training Course will work through a series of Step by Step exercises 
where you can follow the Trainer as they explain how to construct the first 3 pages of a 
Multi Tabbed Dashboard. There will then be a series of Workshop Challenges where you will 
be able to work through to complete the building of a 5-page Dashboard. 

 
Dashboard Requirements 

• As part of any organization it is often a requirement to easily view and display 
the workload of the many teams that operate within a department or business. 

• To enable a line manager or supervisor to have simple access to this information 
without having to build a report or dashboard per team. 

 
Dashboard Design 

Provide a Multi Tabbed Dashboard containing the following 5 Dashboard Pages: 

1. Global Team Dashboard - The Main Page - A Dashboard to show an overview of 
all Calls, Requests and Tasks 

2. Team Calls Workload - Linked from the Main Page to display the overview of the 
Open Calls for a particular team, complete with User Changeable Filters and KPIs. 

3. Analyst Calls Workload - Linked from the Team Calls page to display an overview of 
a particular Analysts current workload. 

4. Team Requests - Linked from the Main Page to display the Open Requests by 
each Workflow Group and also by Location. 

5. Team Tasks - Linked from the Main Page to display the Active Tasks being worked 
on by each Workflow Group. 
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The Dashboard Layout 

1. Global Team Dashboard 

2. Team Calls Workload 
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3. Analyst Calls Workload 

4. Team Requests 
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5. Team Tasks 
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Step by Step and Workshop Challenge Guidance 

1. Items in BOLD are application related, either a button to press or an area of 
the application. 

2. Items in Italics are Data related, either a SQL Table, View or Column (Field Name). 

3. Items in quotations e.g. "Total Calls by Type" are labels or text that is required to 
enter into a widget or label. 
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Step by Step 1 - Creating the Global Team Workload 
Dashboard 

This will produce the following initial first page in the Dashboard, we will return to this 
page in future Workshop Challenges to add additional widgets:  

 
 

 

1. Launch the Alemba Dashboard Designer, using the icon on your desktop.  

2. Rename the Dashboard to "Global Team Workload", as follows: 

• Click on the small pencil icon in the Title field in the top left-hand corner of 
the window. 

 

• In the window, change the title to "Global Team Workload". 

• Click on OK. The name changes in the tab. 
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3. Add a Data Source, as follows: 

• Click the Add icon in the Data Sources container. 
 

 

 

• Complete the details, as follows: 
 

Data Source Name Team Calls 

Connection Type Microsoft SQL Server 

Server Name localhost 

Authentication Type SQL Server Authentication 

User name DBUser 

Password A13mb4 

Database ASM 

 

• Press Connect to establish a connection to the 

Database. The Data Source Design View is displayed: 

 

 

 

If you do not see this, click on the icon in the toolbar - 
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4. Create a virtual table showing all open calls, as follows: 

• In the left-hand pane, expand the Views group if necessary, and locate 
RV_CALL. Alternatively, you can search for it in the Search box. 

• Click and drag it into the work area to create a virtual table. 
 

• Note the number of calls in the Data Preview section, beneath the work area. 

 

• Locate the IPK_Status field and click on the Settings menu and Rename Column 
to be IPK Status (no underscore) 

• To filter the calls to display only open ones, click on the filter icon in the 
Dashboard Config Menu. 

• Click the + Add button at the bottom of the window to add a new filter. 
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• Complete the details as shown below to display Call_Open_Flag Equals 1, 
before clicking Update. 

 

• Note that the number of calls has changed because you are only seeing the 
open calls. 

 

5. Add a logo to the "Global Team Workload "tab, as follows: 

• Scroll to the bottom of the Widget Palette and expand the Miscellaneous group 
if necessary. 

• Click and drag the Image widget onto the top left-hand corner of the 
workspace area. 

• Drag the edges to create a 4x3 square in the top left-hand corner. 

• In the top left corner, change the heading to "AlembaLogo", and click on the 
Assign Data button. 

 

• On the Properties tab, Uncheck Bind from Database, change the Mode to 
Uniform, and click the Set Image… button to browse for the image file. 

• Navigate to your desktop and select the ASMX logo (dark text)200x44.png file. 

 
• Close the AlembaLogo tab. 

6. Add a label to the "Global Team Workload", as follows: 

• Select the Label widget from the Miscellaneous group in the Widget Palette. 

• Click and drag it to the top row beside the logo. 

• Drag the edges to create an 8x2 widget. 
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• Change the heading to "Title” and click on Edit Label. 

• In the window, key in "Global Team Workload" as the text, and format as 
shown, before clicking Apply. 

 

7. Add a Description beneath the label, as follows: 

• Select the Label widget from the Miscellaneous group in the Widget Palette. 

• Click and drag it to the row beside the label. 

• Drag the edges to create an 8x1 widget. 

• Change the heading to "Description" and click on Edit Label. 

 

• In the window, key in “This dashboard provides real time data of the Calls, 
Requests and Tasks owned by each Team in the Service Desk” as the description, 
and format as shown, before clicking Apply. 

 

8. Save your dashboard to ensure that you do not lose your work (File>Save As>” 
Global Team Workload 01.sydx”). 

9. Add a “Total Open Calls” widget, as follows: 

• Select the Card widget from the Deviation group in the Widget Palette. 

• Click and drag it to the top row beside the label. 

• Drag the edges to create a 4x3 widget. 

• Change the heading to "Total Open Calls" and click on Assign Data. 
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• Select the Data tab if necessary. (It should be blue text). 
 

• Locate Call_No in the Measures section. 

• Click and drag it into the Actual Value box. 
 

 It is displayed as Sum(Call_No) by default.  
 

• Click on the Settings button in the Sum(Call_No), and: 

• Select Distinct Count from the drop-down menu. 
 

• Choose Format at the bottom of the Settings menu, and change 
Representation to “Ones”, and set Decimal Places to 0, if necessary, before 
clicking OK. 
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• Select the Properties tab and, in Basic Settings, change the Title Alignment 
to Center. 

• Close the Total Open Calls widget tab. 

10. Save your work (File>Save As>” Global Team Workload 02.sydx”). 

11. Add a Stacked Column chart showing Calls by Group and IPK Status, as follows: 

• Select the Stacked Column widget from the Comparison group in the 
Widget Palette. 

• Click and drag it to the row beneath the logo. 

• Drag the edges to create a 9x9 widget. 

• Change the heading to "Total Calls by Group and IPK Status" and click on 
Assign Data. 

• Select the Data tab if necessary. (It should be blue text). 

 

• Locate Call_No in the Measures section. 

• Click and drag it into the Value(s) box. It is displayed as Sum(Call_No). 

• Click on the Settings button in the Sum(Call_No), and select Distinct Count 
from the drop down menu. 

• In the Dimensions section, locate Call_Current_Group. 

• Drag it into the Column(s) box. 

• In the Dimensions section, locate IPK Status. 
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• Drag it into the Row box. 

• Click on the Settings button  in the IPK Status and select Filter(s) from the drop 
down menu. 

• In the List dropdown field ensure only Incident, Problem, Major Incident, 
Known Error and Service Request statuses are selected. 

 
• Change the legend to be more readable, as follows: 

• on the Properties tab, in the Basic Settings section, click on the Custom… button. 

• Select Group and edit the Display Format (if necessary) to ensure that only 
the row is displayed. You can either edit the text or delete the existing text 
and double click on Row in the box beneath the field, before clicking on OK. 

• Assign the axis properties, as follows: 

• Scroll down to the Axis section, and change the: 

• Category Axis Title to "IPK Group". 

• Primary Value Axis Title to "Number of Calls". 

• Change the display order, so that it is in descending alphabetical order, as follows: 

• In the Column(s) box, click on the Settings button for Call_Current_Group, 
and select Custom Sort... 
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• In the Advanced Sorting Options window, select Sort By Alphabetic, and 
Sort Order Descending, and click on Apply. 

 

12. Add Counts to each column by checking the Show Value Labels option in the 
Basic Settings section and toggling the Total option. 

13. Save your work (File>Save As>” Global Team Workload 03.sydx”). 

14. Click on Preview in the top right-hand corner of the screen to see a user view of 
your dashboard. 
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Step by Step 2 - Creating the Team Calls Workload 
Dashboard 

This will produce the next page in the Dashboard that should resemble the 
following, although the actual figures shown may differ: 

1. If it is not already on screen, launch the Alemba Dashboard Designer, using the icon 
on your desktop. 

2. Open your saved dashboard if necessary, by clicking on Open Dashboard..., or 
Recent Dashboards. 

3. In the menu, click on Dashboard, and then Add Dashboard. 

4. In the Title field in the top left-hand corner, change the name to "Team 
Calls Workload". 
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5. Add a logo widget in a 4x3 grid, as described in the earlier exercise, or you can 
reuse the AlembaLogo widget from the Widgets container on the right-hand side 
of the screen by dragging it onto the Workspace Grid. 

 

6. Add a Label widget in a 4x3 grid, to the right of the logo, which will contain the title 
for the dashboard, as described in the earlier exercise. Give the widget the title 
"Team Calls". 

7. Save your dashboard (File>Save As>” Global Team Workload 04.sydx”). 

8. Add a Team Name widget, as follows: 

• Expand the Filters group in the Widgets Palette if necessary and select 
the ComboBox widget. 

• Click and drag it to the right of the dashboard label widget. Then adjust the size 
to create a 4x2 rectangle. 

• Change the title to "Team Name” and click on Assign Data. 

• On the Data tab, drag Call_Current_Group from the Dimensions section into 
the Display Column. 

• Close the Team Name Filter Widget tab. 

9. Save your work (File>Save As>” Global Team Workload 04.sydx”). 

10. Add a Calls by IPK Status and Priority Stacked Bar Chart, as follows: 

• Expand the Comparison group in the Widgets Palette if necessary and select 
the Stacked Bar widget. 

• Click and drag it to the right of the Team name. Then adjust the size to create 
a 12x6 widget. 

• Change the title to "Calls by IPK Status and Priority "and click on Assign Data. 

• On the Data tab, drag Call_No from the Measures section to the Value(s) box. 

Click on the Settings button in the Sum(Call_No) entry and select Distinct 

Count. 
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• Drag IPK Status from the Dimensions section to the Columns box. 

• Click on the Settings button           for the IPK Status entry and choose Filter(s) 

• Select the List dropdown and deselect all checkboxes apart from Incident, Problem, 
Known Error, Major Incident and Service Request, before clicking Apply, then press 
OK: 

• Drag Call_Priority from the Dimensions section to the Row(s) box. 

 

• Click on the Settings button.         for the Call_Priority entry and choose Custom Sort… 
  

You can search for Call_Priority by keying some of the characters into the 
Search box to the right of the Dimensions section title if you wish. 
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• Select Manual Option and drag the priorities to match the following display, 
before clicking Apply: 

• Drag Problem_Type_Composite from the Dimensions section to the Column(s) 
box, clicking Yes when prompted to enable Multi-Level drill down. 

• On the Properties Tab: 

• Add a SubHeading to say, "Drill Down to Type". 

• In Basic Settings, Select the Custom… button next to Show Legend, select 
Group, and ensure only the Row is displayed, as shown, before clicking OK: 

• Select the Show Value Labels and toggle the Total option. 

• Scroll down to Axis, set the Label Overflow Mode to Hide, and change 
the Primary Value Axis Title to "Number of Calls". 

• Close the Calls by IPK Status and Priority Stacked Bar Chart widget tab 

11. Save your work (File>Save As>” Global Team Workload 05.sydx”). 
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12. Add a Number of Aged Calls Gauge Widget as follows: 

• Expand the Deviation group in the Widgets Palette if necessary and select 
the Radial Gauge widget. 

• Click and drag it to beneath the logo widget. Then adjust the size to create a 
6x3 widget. 

• Change the title to "Number of Aged Calls (>90 days)” and click on the Assign 
Data button. 

• Create the four expressions, as follows: 

• On the Data tab, click the Add button in the Expression Columns section to 
open the Expression Designer 

• Create an expression for the age of calls in days, as follows: 

• In the Expression Designer, click the Add button. 

• Complete the details as follows: 
 

Name CallAgeDays 

Expressi
on 

 

 

 

• Click Save to save the expression. 

• Create an expression for calls older than 90 days by clicking the Add button, 
and completing the details as follows, saving when you are finished: 

 

Name CallsOlder90 

Expressio
n 

 

 

 

• Create an expression for the average call age target by clicking the Add 
button, and completing the details as follow, saving when you are finished: 

 

Name AvgCallAgeTarget 

Expression 50 
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• Create an expression for the expected oldest call age by clicking the Add 
button, and completing the details as follows, saving when you are finished: 

 

Name ExpOldestCallAge 

Expression 180 
 

• With all of the expressions saved, Close the Expression Designer. 

• Drag the CallsOlder90 Expression to the Actual Value box. In the Settings menu: 

• Ensure that Sum is selected 

• Select the Format option, and in the Measure Formatting window, set 
the Representation to “Ones” and the Decimal Places to 0. 

• Drag the AvgCallAgeTarget from the Expression Columns section to the Target Value 

box. Click on the Settings button in the Sum(AvgCallAgeTarget) entry and 
select Average. 

• On Properties Tab: 

• Change SubHeading to say "KPI =No more than 50 Open Aged Calls". 

• Change the Range Colour to Red 

• Set Custom Range Minimum = 0 

• Set Custom Range Maximum=300 

• Set Direction to Low is Good 

• Close the Number of Aged Calls (>90 days) widget. 

11. Save your work (File>Save As>” Global Team Workload 06.sydx”). 

12. Add a widget that shows the Expected Oldest Open Call, as follows: 

• Expand the Deviation group in the Widgets Palette if necessary and select 
the Radial Gauge widget. 

• Click and drag it to beside the Number of Aged Calls (>90days) widget. Then 
adjust the size to create a 6x3 widget. 

• Change the title to "Expected Oldest Open Call >=180 days” and click on the 
Assign Data button. 

• On the Data Tab: 

• Drag the CallsAgeDays Expression to the Actual Value. In the Settings menu: 

• Select Max. 

• Select Format and ensure that the Representation is “Ones” and 
Decimal Places is 0. 
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• Drag the ExpOldestCallAge Expression to the Target Value. In the Settings menu: 

• Select Average. 

• On the Properties tab: 

• Add a SubHeading to say "KPI=No Call to exceed 180 Days Open". 

• Change the Range Colour to Red 

• Set Direction to Low is Good 

• Close the Number of Aged Calls widget. 

13. Save your work (File>Save As>” Global Team Workload 07.sydx”). 

14. Add a Pivot Grid that shows Calls per Team Analyst. 

• Expand the Relationship group in the Widgets Palette if necessary and 
select the PivotGrid widget. 

• Click and drag it to beneath the Number of Aged Calls widget. Then adjust 
the size to create a 24x6 widget that extends across the dashboard. 

• Change the title to "Calls per Team Analyst” and click on the Assign 
Data button. 

• On the Data tab: 

• Locate Call_No in the Measures section and drag it to the Value(s) 

• In the Settings menu: 

• Select Distinct Count 

• Choose Format and change Representation to “Ones” (if 
necessary) and set Decimal Places to 0. 

• Locate CallAgeDays in the Expression Columns section, and drag it 
to Value(s) 

• In the Settings menu: 

• Select Average 

• Choose Format and change Representation to “Ones” (if 
necessary) and set Decimal Places to 0. 

• Locate CallsOlder90 in the Expression Columns section, and drag it 
to Value(s) 

• In the Settings menu: 

• Select Distinct Count 

• Choose Format and change Representation to “Ones” (if 
necessary) and set Decimal Places to 0. 
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• Locate Call_Current_Officer in the Dimensions section, and drag it to 
the Row(s) 

• On the Properties tab: 

• Under Column Settings, click on Edit Column Names, and update 
the details as follows, before clicking OK: 

 

• Close the Pivot Grid widget. 

15. Save your work (File>Save As>” Global Team Workload 08.sydx”). 

16. Preview your dashboard, by clicking on the Preview button in the top right corner 
of the screen. 

  



Alemba User Conference 2019: Alemba Service Manager Skills 
 

29 Version 1.0 

© Alemba 
2018 

Alemba Dashboard Designer 

 

 

Step by Step 3 - Linking the Dashboard Pages 

In this exercise, we will link the Global Team Workload page and the Team Calls 
Workload dashboard page. 

1. If it is not already on screen, launch the Alemba Dashboard Designer, using the icon 
on your desktop. 

2. Open the Global Team Workload dashboard. You can use File>Open or select it 
from the pane on the right hand side of the screen. 

3. Select the Total Calls by Group and IPK Status Stacked Column Chart. 

4. Click on Assign Data, and display the Properties tab. 

5. Under the Link menu item, do the following: 

• Enable Linking 

• Select Internal 

• Choose the “Team Calls Workload” dashboard in the Tab dropdown. 

• Select Set Parameters and complete the details as follows, before clicking OK: 

• Target Column = “Call_Current_Group” 

• Source Widget = “Total Calls by Group and IPK Status” 

• Source Column = “Call_Current_Group” 

6. Return to the Global Team Workload Dashboard and click Preview to preview the 
dashboard. 

7. Click on one of the columns in the Total Calls by Group and IPK Status bar chart on the 
Global Team Workload page to view calls for a specific team. You should see the Team 
Calls page display, with the relevant team name (and linked chart widgets) selected. 
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Step by Step 4 - Creating the Analyst Calls Dashboard 

This will create the following new dashboard page: 

1. If it is not already on screen, launch the Alemba Dashboard Designer, using the icon 
on your desktop. 

2. Open your dashboard if necessary, by clicking on Open Dashboard..., or 
Recent Dashboards. 

1. Add a new tab to the Dashboard to build the Analyst Calls widgets, as follows: 

• Select the Add button in the Dashboards Container. 

• Rename the Tab to "Analyst Calls Workload". 

2. Add the logo to the dashboard, as you have done in previous exercises, as follows: 

• Scroll to the bottom of the Widget Palette and expand the Miscellaneous group 
if necessary. 
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• Click and drag the Image widget onto the top left-hand corner of the 
workspace area. 

• Drag the edges to create a 4x3 square in the top left-hand corner. 

• In the top left corner, change the heading to "AlembaLogo", and click on 
Assign Data. 

• On the Properties tab, uncheck Bind from Database, change the Mode to 
Uniform, and click the Set Image… button to browse for the image file. 

• Navigate to your desktop and select the ASMX logo (dark text)200x44.png file. 

• Close the AlembaLogo tab. 

3. Click to select the Analyst Calls Workload tab if necessary. 

4. Add a label to the dashboard. 

• Select the Label widget from the Miscellaneous group in the Widget Palette. 

• Click and drag it to the top row beside the logo. 

• Drag the edges to create an 8x2 widget. 

• Change to heading to "Analyst Calls Workload “ and click on Edit Label. 

• Enter "Analyst Calls Workload" as the text, and format as shown, before clicking 
on Apply. 

 

5. Add an Analyst Name Filter Widget, as follows: 

• Expand the Filters group in the Widgets Palette, if necessary, and select 
the ComboBox widget. 

• Click and drag it to the right of the label. Then adjust the size to create an 
8x1 rectangle. 

• Change the title to "Analyst Name” and click on Assign Data. 
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• On the Data tab, drag Call_Current_Officer from the Dimensions section into 
the Display Column. 

• Close the tab (click to select the Analyst Calls Workload tab if necessary). 

6. Save your work (File>Save As>” Global Team Workload 09.sydx”) 

7. Add a Grid Widget to display the Analysts Calls, as follows: 

• Scroll to the Relationship group of the Widget Palette. 

• Click and drag the Grid widget onto the left-hand corner of the workspace 
area, below the Image and the Label. 

• Drag the edges to create a 12x9 square. 

• In the top left corner, change the heading to "Call Details", and click on Assign Data. 

• On the Data Tab: 

• Locate Call_No in the Measures section and drag it to the Column(s) 

• In the Settings menu: 

• Select None 

• Choose Format and change Representation to “Ones” (if necessary) 
and set Decimal Places to 0. 

• Drag the following from the Dimension(s) section to the Column(s) section. 
(You can use the Search button or scroll up and down.) 

• Customer 

• Problem_Type_Composite 

• Call_Priority 

• IPK Status 

• Locate CallAgeDays in the Expression Columns section, and drag it to Value(s) 

• In the Settings menu: 

• Select None 

• Choose Format and change Representation to “Ones” (if necessary) 
and set Decimal Places to 0. 
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• On the Properties Tab: 

• Under Column Settings, press the Edit Column Names button and update 
the column titles: 

• Under Column Settings select Template. 

• Select CallAgeDays Column and select Conditional Formatting, press Edit… 

• Press the Add Button (+) 

• Select CallAgeDays, and set the details as shown: Condition Type 
Greater than or Equal To, Values= 90 Font Color to Red and Background 
to White. 

• Press OK and Close. 

• Select Call_Priority Column and select Conditional Formatting, press Edit... 

• Press the Add Button 
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• Change the details, as shown. 
 

• Press OK, Close and Update. 

• In the Column Settings section of the Properties tab click on Sort... 

• Set Sort Order to Descending 

• Set Value(s) to Call_No (None) 

• Press OK. 

• Ensure Allow Paging is selected in the Basic Settings. 

• Close the Call Details Grid tab. 

• Save your work (File>Save As>” Global Team Workload 10.sydx”) 

8. Add a TreeMap Widget to show priority calls. 

• Expand the Relationships group in the Widgets Palette, if necessary, and select 
the TreeMap widget. 

• Click and drag it to next to the Analyst Name Filter. Then adjust the size to 
create 8x15 rectangle. 

• Change the title to "Priority Calls” and click on Assign Data. 

• On the Data tab, drag Call_No from the Measures section into the Value(s) column. 

• In the Settings menu: 

• Select Distinct Count 

• Choose Format and change Representation to “Ones” (if necessary) and 
set Decimal Places to 0. 

• Drag Call_Priority from the Dimensions section to the Group By Section. 
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• On the Properties Tab, scroll to the Range Colour Settings, select Range Brush 
Items and set Low to Blue, Medium to Yellow/Orange and High to Red. 

• Close the tab. 

9. Save your work (File>Save As>” Global Team Workload 11.sydx”). 

10. Add a picture of the analyst, as follows: 

• Open the “Team Calls” Data Source. 

• Locate the Call_Current_Officer_Ref field and click on the Settings menu and 
change the Column Type to Text. This will allow you to pass the correct value 
for the Analyst from the ASM database into the linked image URL to retrieve 
the Analysts Image. 

• Add an Image widget to the top right hand of the Analyst Calls dashboard page. 

• Drag the edges to form a 4x3 square. 

• Change the heading to "Analyst Photo', and click on Assign Data. 

• On the Data Tab drag the Call_Current_Officer_Ref to the Column(s). 

• On the Properties Tab: 

• Change the Mode to Default. 

• Change the Image Source to URI. 

• Change the Pattern to point to the location of the image files, note {0} variable 
E.G. http://localhost/ASM/dashboards/{0}.jpg 

• Close the tab. 

9. Add a Card Widget that shows the total number of calls. 

• Expand the Deviations group in the Widgets Palette, if necessary, and select 
the Card widget. 

• Click and drag it to below the Analyst Picture Image, and then adjust the size 
to create a 3x4 rectangle. 

• Change the title to "Total Open Calls” and click on Assign Data. 

• On the Data tab, drag Call_No from the Dimensions section into the Actual Value. 

• In the Settings menu: 

• Select Distinct Count 

• Choose Format and change Representation to “Ones” (if necessary) and 
set Decimal Places to 0. 

• Close the tab. 

10. Add a Date Filter. 
  

http://localhost/ASM/dashboards/%7b0%7d
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• Expand the Filters group in the Widgets Palette, if necessary, and select the 
Date Picker widget. 

• Click and drag it to below the Card Widget. Then adjust the size to create a 
2x4 rectangle. 

• Change the title to "Logged in Period” and click on Assign Data. 

• On the Data tab, drag Call_Log_Date from the Dimensions section into the Column. 

• On the Properties tab, under Basic Settings set Selection Type to Range. 

• Close the tab. 

11. Add a Checkbox Filter 

• Expand the Filters group in the Widgets Palette, if necessary, and select 
the CheckBox widget. 

• Click and drag it to below the Date Filter. Then adjust the size to create a 
4x4 rectangle. 

• Change the title to "IPK Status” and click on Assign Data. 

• On the Data tab, drag IPK Status from the Dimensions section into the Column. 

• Close the tab. 

12. Save your work (File>Save As>” Global Team Workload 12.sydx”) 

13. Preview the Dashboard. 
  



Alemba User Conference 2019: Alemba Service Manager Skills 
 

37 Version 1.0 

© Alemba 
2018 

Alemba Dashboard Designer 

 

 

Step by Step 5 - Linking the Team Calls Workload 
Dashboard to the Analyst Calls Workload Dashboard 

In this exercise, we will link the Call Teams Workload page and the Analyst Calls 
Workload dashboard page. 

1. If it is not already on screen, launch the Alemba Dashboard Designer, using the icon 
on your desktop. 

2. Open the Team Calls Workload dashboard. 

3. Select the Calls per Team Analyst Pivot Grid Widget. 

4. Click on Assign Data and display the Properties Tab. 

5. Under Link, select Enable Linking. 

6. Select Internal. 

7. Choose the “Analyst Calls Workload” dashboard in the Tab dropdown. 

8. Select Set Parameters and complete the details as follows, before clicking OK: 

• Target Column = “Call_Current_Officer” 

• Source Widget = “Calls per Team Analyst” 

• Source Column = “Call_Current_Officer” 

8. Return to the Team Calls Dashboard and click Preview to preview the dashboard. 

9. Click on one of the columns in the Total Calls by Group and IPK Status bar chart to 
view calls for a specific team. You should see the Team Calls tab with the relevant 
team name (and linked Chart Widgets) selected. 

10. Click on one of the analysts’ names in the Calls per Team Analyst chart to view calls for 
that Analyst. You should see the Analyst Calls Workload Dashboard Tab filtered for that 
Analyst and displaying their photograph. 
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Workshop Challenge 1- Creating a New Data Source for 
Requests 

This challenge will create a new Data Source to use with additional Widgets added to 
the Global Team Workload dashboard page (Workshop Challenge 2) and to the new 
Team Requests dashboard page (Workshop Challenge 3). 

1. If it is not already on screen, launch the Alemba Dashboard Designer, using the icon 
on your desktop. 

2. Go to File>Open to load the Global Team Workload Dashboard. 

3. Add a Data Source, as follows: 

• Click the Add icon in the Data Sources container. 
 

 

• Complete the details, as follows: 
 

Data Source Name Team Requests 

Connection Type Microsoft SQL Server 

Server Name <ServerName> 

Authentication Type SQL Server Authentication 

User name DBUser 

Password A13mb4 

Database ASM 

 

• Press Connect to establish a connection to the Database. 
  

 

If you do not see this, click on the icon in the toolbar 



Alemba User Conference 2019: Alemba Service Manager Skills 
 

39 Version 1.0 

© Alemba 
2018 

Alemba Dashboard Designer 

 

 

The Data Source Design View is displayed: 
 

4. Create a virtual table showing all open requests, as follows: 

• In the left-hand pane, expand the Views group if necessary, and 
locate RV_REQUEST. Alternatively, you can search for it in the Search 
box. 

• Click and drag it into the work area to create a virtual table. 

• Note the number of Requests. 

• To filter the Requests to display only open ones, click on the Filter button in 
the toolbar. 

• Click the + Add button at the bottom of the window to add a new filter. 
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• Complete the details as shown below to display Req_Open_Flag Equals 1, 
before clicking Update. 

• Note that the number of Requests has changed because you are only seeing 
the open requests. 

2. Next add another View and merge the data as follows: 

• In the left-hand pane, expand the Views group if necessary, and 
locate RV_LOCATIONS. Alternatively, you can search for it in the 
Search box. 

• Click and drag it into the work area to create a virtual table: 

• When prompted in the Join Editor, ensure RV_REQUEST is joined to 
RV_LOCATIONS via a LEFT OUTER JOIN and that REQ_LOCATION_REF equals 
LOCATION_REF 

 

• Then press Merge to complete the data join. 

• Close the Team Requests Data Source. 

• Save the Dashboard (File>Save As>”Global Team Workload 12.sydx”). 
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Workshop Challenge 2 - Update the Global Team 
Workload Dashboard with Request Widgets 

This challenge will update the main Global Team Workload dashboard page with two 
extra widgets that can be used to drill down into another Team Requests dashboard page 
to be created in Workshop Challenge 3. 

1. Open your saved dashboard if necessary, by clicking on Open Dashboard..., or 
Recent Dashboards. 

2. Click on the dashboard tab for the Global Team Workload 

Dashboard. Your dashboard should look like this: 

 

3. Add a Total Open Requests widget, as follows: 

• Select the Card widget from the Deviation group in the Widget Palette. 

• Click and drag it to the top row beside the label. 

• Drag the edges to create a 4x3 widget. 

• Change the heading to "Total Open Requests" and click on Assign Data. 

• Select the Data tab if necessary. (It should be blue text). 

• Ensure the Team Requests Data Source is selected. 
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• Locate Req_No in the Measures section. 

• Click and drag it into the Actual Value box. 

 

 It is displayed as Sum(Req_No).  
 

• Click on the Settings button in the Sum(Req_No), and: 

• Select Distinct Count from the drop-down menu. 

 

• Choose Format at the bottom of the menu and change Representation 
to “Ones” and set Decimal Places to 0, if necessary, before clicking OK. 
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• Select the Properties tab, and in Basic Settings, change the Title Alignment 
to Center. 

• Close the Total Open Requests widget. 

4. Save your work (File>Save As>” Global Team Workload 13.sydx”). 

5. Add a New Custom Widget, as follows: 

• Go to File>Widget. 

• Select Manage Custom Widgets. 
 

• In the Manage Custom Widgets window click on Add Widget. 

 

• In the File Explorer window, navigate to the location: 

c:\ProgramData\Syncfusion\DashboardDesigner\Custom Widgets\ 

• Select the SunburstChart.sycw file and press Open. 

• Press Close on the Manage Custom Widgets window. 

• The new chart visualization should now be in the Relationships section of 
the Toolbox Pane: 
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6. Add a sunburst chart showing Total Requests by Group and Type, as follows: 

• Select the Sunburst Chart widget from the Relationship group in the Widget Palette. 

• Click and drag it to the space next to the Bar Graph. 

• Drag the edges to create a 9x9 widget, similar size to the Bar Chart. 

• Change the heading to "Total Requests by Group and Type" and click on 
Assign Data. 

• Select the Data tab if necessary (it should be blue text). 

• Ensure the Team Requests Data Source is selected in the dropdown. 

• Locate Req_No in the Measures section. 

• Click and drag it into the Value(s) box. It is displayed as Sum(Req_No). 

• Click on the Settings button in the Req_No, and select Distinct Count from 
the drop down menu. 

• In the Dimensions section, locate Req_Current_Group. 

• Drag it into the Levels box. 

• In the Dimensions section, locate Req_Type_Composite. 

• Drag it into the Levels box, below Req_Current_Group. 

• Your screen should look like this: 
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• On the Properties Tab in Basic Settings, uncheck Show Legend. 

• Close the Total Requests by Group and Type tab. 

7. Save your work (File>Save As>” Global Team Workload 14.sydx”). 

8. Click on Preview in the top right-hand corner of the screen to see a user view of 
your dashboard. 
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Workshop Challenge 3 - Creating the Team Requests 
Workload Dashboard 

This will produce a fourth page in the Dashboard that should resemble the 
following, although the actual figures shown may differ: 

1. Open your saved dashboard if necessary, by clicking on Open Dashboard..., or 
Recent Dashboards. 

2. In the menu, click on Dashboard, and then Add Dashboard. 

3. In the Title field in the top left-hand corner, change the name to "Team Requests". 

4. Add the logo widget in a 4x3 grid, as described in the earlier exercise, or you can 
reuse the AlembaLogo widget from the Widgets container on the right-hand side of 
the screen by dragging it onto the Workspace Grid. 
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5. Add a Label widget in an 8x2 grid, to the right of the logo, which will contain the title 
for the dashboard, as described in the earlier exercise. Give the label the title "Team 
Requests". 

6. Add a Team Name widget, as follows: 

• Expand the Filters group in the Widgets Palette if necessary and select 
the ComboBox widget. 

• Click and drag it below the dashboard label. Then adjust the size to create an 
8x1 rectangle. 

• Change the title to "Team Name", and click on Assign Data. 

• On the Data tab, make sure Team Requests is selected in the drop down (top 
right hand of the Data Tab) and drag Req_Current_Group from the Dimensions 
section into the Display Column. 

• Close the tab. 

10. Save your work (File>Save As>” Global Team Workload 15.sydx”). 

11. Add a Number of Requests Logged per Customer Stacked Column Chart 

• Expand the Comparison group in the Widgets Palette if necessary and select 
the Stacked Column widget. 

• Click and drag it to below the logo. Then adjust the size to create a 12x9 widget. 

• Change the title to "Number of Requests Logged per Customer" and click on 
Assign Data. 

• On the Data tab, ensure the “Team Requests” Data Source is selected 

 

• Drag Req_No from the Measures section to the Value(s) box. Click on 

the Settings button         in the Sum(Req_No) entry and select Distinct 

Count. 

• Drag Req_Customer from the Dimensions section to the Column(s) box. 

• Drag Req_Priority from the Dimensions section to the Row box. 

• On the Properties Tab: 
  

You can search for Req_Priority by keying some of the characters into the 
Search box to the right of the Dimensions section title if you wish. 
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• In Basic Settings, Select the Custom... button next to Show Legend, select 
Group, and ensure only the Row is displayed in the Display Format, as shown, 
before clicking OK: 

 

• Scroll down to Axis and change the Primary Value Axis Title to "Number 
of Requests". 

• Change the Category Axis Title to "Customers". 

• Close the Calls by IPK Status tab. 

• Save your work (File>Save As>” Global Team Workload 16.sydx”). 

12. Add a Number of Requests by Location Choropleth Map widget, as follows: 

• Expand the Relationship group in the Widgets Palette if necessary and select 
the Choropleth Map widget. 

• Click and drag it into the remaining space next to the Stacked Column Chart 
and Label Widgets. Then adjust the size to create a 12x15 widget. 

• Change the title to "Number of Requests by Location", and click on the Assign 
Data button: 

• On the Data Tab: 

• Drag Req_No from the Measures section to the Value box. Click on the 

Settings button         in the Sum(Req_No) entry and select Distinct Count. 

• Drag Location_Country from the Dimensions section to the Shape box. 

• On the Properties tab: 

• In Basic Settings, enable the Show Legend check box. 

• Close the widget. 

13. Save your work (File>Save As>” Global Team Workload 17.sydx”). 
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14. Preview your dashboard, by clicking on the Preview button in the top right corner 
of the screen. 
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Workshop Challenge 4 - Linking the Global Team 
Workload Dashboard Page to the Team Requests Page 

In this exercise, we will link the Global Team Workload and Team Requests 
Workload dashboard tabs. 

1. Select the Total Requests by Group and Type Sunburst Chart. 

2. Click on Assign Data, and display the Properties tab. 

3. Under the Link menu item, do the following: 

• Enable Linking 

• Select Internal 

• Choose the “Team Requests” dashboard in the Tab dropdown 

• Select Set Parameters and complete the details as follows, before clicking OK: 

• Target Column = “Req_Current_Group” 

• Source Widget = “Total Requests by Group and Type” 

• Source Column = “Req_Current_Group” 

4. Return to the Global Team Workload Dashboard and click Preview to preview 
the dashboard. 

5. Click on one of the segments in the Total Requests by Group and Type Sunburst 
Chart on the Global Team Workload page to view Requests for a specific Workflow 
Group. You should see the Team Requests page, with the relevant team name (and 
linked chart widgets) selected. 
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Workshop Challenge 5 - Creating the Team Tasks 
Workload Dashboard 

This will produce a fifth page in the Dashboard that should resemble the following, 
although the actual figures shown may differ: 

1. Open your saved dashboard if necessary, by clicking on Open Dashboard..., or 
Recent Dashboards. 

2. Add a Data Source, as follows: 

• Click the Add icon in the Data Sources container. 

 
 

• Complete the details, as follows: 
 

Data Source 
Name 

Team Tasks 

Connection 
Type 

Microsoft SQL Server 

 

  

 

If you do not see this, click on the icon in the toolbar 
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Server Name localhost 

Authentication 
Type 

SQL Server Authentication 

User name DBUser 

Password A13mb4 

Database ASM 
 

• Press Connect to establish a connection to the 

Database. The Data Source Design View is displayed: 

3. Create a virtual table showing all active tasks, as follows: 

• In the left-hand pane, expand the Views group if necessary, and locate 
RV_TASK. Alternatively, you can search for it in the Search box. 

• Click and drag it into the work area to create a virtual table. 

 

• Note the number Tasks. 

• To filter the Tasks to display only Active ones, click on the Filter button in 

the toolbar.  

• Click the + Add button at the bottom of the window to add a new filter. 
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• Complete the details as shown below to display Task_Active_Flag Equals 1, 
before clicking Update. 

• Note that the number of Tasks has changed because you are only seeing the 
active Tasks. 

4. Update the Global Team Workload page, add a Total Active Tasks widget, as follows: 

• Select the Card widget from the Deviation group in the Widget Palette. 

• Click and drag it to the top row beside the Total Open Requests Card Widget. 

• Drag the edges to create a 4x3 widget. 

• Change the heading to "Total Active Tasks" and click on Assign Data. 

• Select the Data tab if necessary (it should be blue text). 

• Ensure the Team Tasks Data Source is selected. 

• Locate Task_No in the Measures section. 

• Click and drag it into the Actual Value box. 

 

 It is displayed as Sum(Task_No).  
 

• Click on the Settings button in the Sum(Task_No) 

• Select Distinct Count from the drop-down menu. 

• Choose Format at the bottom of the menu and change Representation 
to “Ones” and set Decimal Places to 0, if necessary, before clicking OK. 

• Select the Properties tab, and in Basic Settings, change the Title Alignment 
to Center. 

• Close the Total Active Tasks widget. 

5. Save your work (File>Save As>” Global Team Workload 18.sydx”). 

6. Update the Global Team Workload page, add a Tree Map showing Total Active 
Tasks by Task Type, as follows: 

• Select the TreeMap Chart widget from the Relationship group in the Widget Palette. 
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• Click and drag it to the space next to the Bar Graph. 

• Drag the edges to create a 6x9 widget. 

• Change the heading to "Total Active Tasks by Task Type" and click on Assign Data. 

• Select the Data tab if necessary. (It should be blue text). 

• Ensure the TeamTasks Data Source is selected in the dropdown. 

• Locate Task_No in the Measures section. 

• Click and drag it into the Value(s) box. It is displayed as Sum(Task_No). 

• Click on the Settings button in the Task_No, and select Distinct Count 
from the drop down menu. 

• In the Dimensions section, locate Task_Type. 

• Drag it into the Group by box. 

• Your screen should look like this: 

• Close the Total Active Tasks by Task Type tab. 

7. Save your work (File>Save As>” Global Team Workload 19.sydx”). 

8. Click on Preview in the top right-hand corner of the screen to see a user view of 
your dashboard. 
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9. Now add a new Team Tasks Dashboard, in the menu, click on Dashboard, and then 
Add Dashboard. 

10. In the Title field in the top left-hand corner, change the name to "Team 
Tasks Workload". 

11. Add the logo widget in a 4x3 grid, as described in the earlier exercise, or you can 
reuse the AlembaLogo widget from the Widgets container on the right-hand side of 
the screen by dragging it onto the Workspace Grid. 

12. Add a Label widget in an 8x2 grid, to the right of the logo, which will contain the 
title for the dashboard, as described in the earlier exercise. Give the dashboard the 
title "Team Tasks". 

13. Save your dashboard (File>Save As>” Global Team Workload 19.sydx”). 

14. Add a Planned Task Start Date Date Picker filter widget, as follows: 

• Expand the Filters group in the Widgets Palette if necessary and select 
DatePicker widget. 

• Click and drag it to below the dashboard label. Then adjust the size to create an 
8x1 rectangle. 

• Change the title to "Planned Task Start Date” and click on Assign Data. 

• On the Data tab, make sure Tasks is selected in the drop down (top right hand 
of the Data Tab): 

• Drag Task_Planned_Start_Date from the Dimensions section into the Column. 

• Click on the Settings button in the Sum(Task_No) entry and 
select Distinct Count. 

• Drag the Task_Planned_Start_Date from the Dimensions section to 
the Argument section. 

• On the Properties Tab change the Selection Type to Range. 

• Close the tab. 

15. Save your work (File>Save As>” Global Team Workload 20.sydx”). 

16. Add a Grid widget to display Task Information: 
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• Expand the Relationship group in the Widgets Palette if necessary, and select 
the Grid widget. 

• Click and drag it to below the logo. Then adjust the size to create a 24x12 widget. 

• Change the title to "Task Details" and click on Assign Data. 

 

• On the Data tab, ensure the Tasks Data Source is selected. 

• Drag Task_No from the Measures section to the Value(s) box. Click on 

the Settings button         in the Sum(Task_No) entry and select None. 

• Drag Req_No from the Measures section to the Value(s) box. Click on 

the Settings button         in the Sum(Req_No) entry and select None. 

• Drag Task_Title from the Dimensions section to the Column(s) box. 

• Drag Task_Priority from the Dimensions section to the Column(s) box. 

• Drag Task_Status from the Dimensions section to the Column(s) box. 

• Drag Task_Current_Officer from the Dimensions section to the Column(s) box. 

• Drag Task_Current_Group from the Dimensions section to the Column(s) box. 

• Drag Task_Planned_Start_Date from the Dimensions section to the Column(s) 

box. Click on the Settings button in the Year(Task_Planned_Start_Date) 
entry and select Date Time. 

• On the Properties Tab: 

• In Column Settings, Select the Edit Column Names... button and modify 
the column names: 
Scroll down to Axis, and change the Primary Value Axis Title to "Number of Tasks" 

• In the Basic Settings section enable Fit to Content. 

• Close the Task Details tab. 

17. Save your work (File>Save As>” Global Team Workload 21.sydx”). 

18. Add a Number of Active Tasks per Group Card Widget as follows: 

• Expand the Deviation group in the Widgets Palette if necessary and select the 
Card widget. 

• Click and drag it to next to the Label and Date Picker Filter Widget. Then adjust 
the size to create a 12x3 widget. 

• Change the title to "Number of Active Tasks per Group” and click on the 
Assign Data button. 

  

You can search for Task_Priority by keying some of the characters into 
the Search box to the right of the Dimensions section title if you wish. 
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• Drag Task_No from the Measures section to the Actual Value(s) box. Click on 

the Settings button         in the Sum(Task_No) entry and select Distinct Count. 

• Drag Task_Current_Group from the Dimensions section to the Series. 

• Close the Number of Tasks per Group widget. 

19. Save your work (File>Save As>”Global Team Workload 22.sydx”). 

20. Preview your dashboard, by clicking on the Preview button in the top right corner 
of the screen. 
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Workshop Challenge 6 - Setting Dashboard Refresh 
Options 

 
1. Launch the Alemba Dashboard Designer, using the icon on your desktop. 

2. Go to File>Open to load the Global Team Workload Dashboard. 

3. Go to the Dashboard>Refresh Settings menu item. 

4. In the Refresh Settings window select Enable Auto Refresh on the Global 
Team Workload Dashboard Page. 

5. Ensure the Dashboard Option is selected and then press the Set Timer button: 
 

 

6. Change the Timer to refresh the Dashboard Page every 5 Minutes and then press 
the Set button: 

7. Select the Team Calls Workload Dashboard Page. 

8. Select the Enable Auto Refresh option then toggle so that the Widget(s) option 
is selected. 

9. Check all the widgets that contain gauges, grids or chart information (not the 
Layout Widgets or Filters). 
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10. On the Calls by IPK Status and Priority widget choose the Set Timer option from the 
3 Dot Menu icon and set the refresh setting to 5 seconds. 

 

 

11. For the remaining Widgets either set an appropriate timer frequency or from the 3 
Dot Menu choose Apply Timer From and select the Calls by IPK Status and Priority 
item to copy the refresh timer. 

12. If you wish, repeat Steps 7 to 11 for the Analyst Calls Workload, Team Requests 
and Team Tasks Dashboard pages. 

13. Press OK on the Refresh Settings window to apply the settings. If you need to alter 
these at any time, then you can return to these settings at any time by going to 
the Dashboard>Refresh Settings menu item. 
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Publishing a Dashboard to the Dashboard Server 

1. If the Dashboard Designer is already logged in as a user proceed to Step 4, 

otherwise click on the User Icon in the top right-hand corner of the Designer. 

2. Choose New User Login. 

3. Enter the Server URL and Username/Password for a Dashboard Server User, 
press Login. 

4. Go to the Server>Publish>Dashboard Menu: 

 

5. In the Publish Dashboard window give the Dashboard a name with your initials 
e.g. GlobalTeamWorkload_XXX, ensure Mark as Public is selected then press 
Publish button: 
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6. When the Dashboard has been published then you are able to view the 
Dashboard from the Dashboard Server by pressing the Yes button: 

 
 
 
 
 
 
 

7. Save your work (File>Save As>”Global Team Workload 23.sydx”). 

8. Close the Dashboard Designer (File>Exit). 
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Troubleshooting 
 
Improving Dashboard Performance 

1. Create views 

Lots of join operations take more time. If you find yourself creating a data connection 
with many tables, you can create a view in the database for those joined tables. It will 
help to improve the performance of the dashboard. Also, it will simplify the view in 
dashboard designer. 

Tables (Joined): 

Views: 
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2. Create initial filter 

Filter data as early as possible. For example, if your dashboard shows data for a certain 
date range, time range, a specific set of regions etc., using initial filter at the earlier stage 
can help to improve the performance. 

 

 

3. Remove unused columns 

Reduce the number of columns in the table schema from the dashboard designer view 
by manually excluding the unused columns. 

 

4. Avoid creating complex expressions 

The following actions may improve dashboard performance: 

• If possible, avoid or reduce complex expressions. 

• Avoid creating filters for calculated dimensions. 
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5. Avoid changing datatype 

Datatype change in designer reduces the performance. If possible, do datatype changes 
in the database itself. 

 
 

6. Avoid using too many widgets 

Don’t use too many widgets in one single dashboard. If you have used many widgets, 
move to another dashboard using multiple dashboard option. 

 

7. Aggregate the raw data 

If the granularity of your raw data is higher than the data you intend to display, aggregate 
it to the smallest granularity you need. If possible, aggregate the raw data instead of using 
"None" option or "Enable Data Grouping" option in dashboard. 

 

 

8. Moving file type data to server 

If you’re using file type database such as Excel, CSV, JSON, before connecting dashboard 
designer, move your data to another server like SQL. It will improve your overall 
dashboard performance. 
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Further Information 
 
Product Information and Online Support 

For information about Alemba products, licensing and services, visit www.alemba.com. 

For release notes and software updates, go to www.alemba.help. 

Up-to-date product documentation, training materials and videos can be found 
at www.alemba.help/help. 

 You may need to register to access some of these details.  

 
Technical Support 

For technical support, please visit: and select the ASM support link. You will need to log in 
to the Alemba self service portal to contact the Alemba Service Desk. 

 
Comments and Feedback 

If you have any comments or feedback on this documentation, submit it 
to info@alemba.com. 

http://www.alemba.com/
http://www.alemba.help/
http://www.alemba.help/help
mailto:info@alemba.com.

